| X/Open Portability Guide, X/Open Company Limited, published by Prentice Hall, Englewood Cliffs, N.J., 1988, pages. |
| "Protocol Conversion" by Paul E. Green, Jr., IEEE Transactions on Communications, vol. COM-34, No. 3, Mar. 1986, pp. 257-268. |
| "TACT: A Protocol Conversion Toolkit" by Joshua Auerbach, IEEE Journal on Selected Areas in Communications, vol. 8, No. 1, Jan. 1990, pages 143-159. |
| "Transition and Coexistence Strategies for TCP/IP to OSI" by Marshall T. Rose, IEEE Journal on Selected Areas in Communications, vol. 8, No. 1, Jan. 1990, pp. 57-66. |
| "Conversion Between the TCP and ISO Transport Protocols as a Method of Achieving Interoperability Between Data Communications Systems" by Inge Groenbaek, IEEE Journal on Selected Areas in Communications, vol. SAC-4, No. 2, Mar. 1986, pp. 288-296. |
| "Design Principles for Communication Gateways" by Gregor V. Bochmann and Pierre Mondain-Monval, IEEE Journal on Selected Areas in Communications, vol. 8, No. 1, Jan. 1990, pp. 12-21. |
| "Network Interconnection and Gateways" by Carl A. Sunshine, IEEE Journal on Selected Areas in Communications, vol. 8, No. 1, Jan. 1990, pp. 4-11. |
| "Protocol Standard for a NetBIOS Service on a TCP/UDP Transport: Concepts and Methods", Defense Advanced Research Projects Agency, Internet Activities Board, End-to-End Services Task Force, NetBIOS Working Group, RFC 1001, Mar. 1987. |
| "ISO Transport Services on Top of the TCP: Version 3" by M. T. Rose and D. E. Cass, RFC 1006, May 1987. |
| "Protocol Standard for a NetBIOS Service on A TCP/UDP Transport: Detailed Specification", RFC 1002, Mar. 1987. |
| Unix Programmers Manual Reference Guide, Computer Science Division, Dept. of Electrical Engineering and Computer Science, University of California at Berkley, Apr. 1986. |